Problem with WD Marvel Demo

Questions about Wdmarvel capabilities
Аватара пользователя
Vlad
Разработчик
Сообщения: 4815
Зарегистрирован: 13 авг 2013, 07:53

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Vlad »

Looks like drive not want accept VSC via TLL in your case
115200 N 8
Severence
Сообщения: 33
Зарегистрирован: 01 янв 2017, 10:28

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Severence »

that certainly does appear to be the case :(

playing around - tried checking for modules and tx/rx light up rapidly - is that any indication that the drive is indeed at the very least responding?

do you think "restart and block loading FW by changing Rom image" would work?

slightly off topic question for you vlad, are you able to determine in software/commands if a particular WD drive is utilizing an internal flash rom, or an external flash rom or a parallel flash rom?

If yes, are you able to instruct the mcu to use one or the other or both in software/ through commands?
Аватара пользователя
Vlad
Разработчик
Сообщения: 4815
Зарегистрирован: 13 авг 2013, 07:53

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Vlad »

I can not detects what happens by tx/rx blinking :)
When you enter to work with modules, is some error?
No, at one of my first posts in this topic I list all WD rom commands, read/write/erase
Severence
Сообщения: 33
Зарегистрирован: 01 янв 2017, 10:28

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Severence »

Vlad писал(а):I can not detects what happens by tx/rx blinking :)
When you enter to work with modules, is some error?
No, at one of my first posts in this topic I list all WD rom commands, read/write/erase
When hitting the modules button i get

15/03/2017 13:40:31: The error in determining the number of heads
15/03/2017 13:40:42: Error reading module Dir, state - Drive do not acknowledged receipt of the command

when hitting "check all modules" i just get

tx/rx blinky blink blinky ;)
15/03/2017 13:41:31: Looking for modules, found 0
Аватара пользователя
Vlad
Разработчик
Сообщения: 4815
Зарегистрирован: 13 авг 2013, 07:53

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Vlad »

This:
Drive do not acknowledged receipt of the command
mean, VSC not work in this mode
Severence
Сообщения: 33
Зарегистрирован: 01 янв 2017, 10:28

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Severence »

Vlad писал(а):This:
Drive do not acknowledged receipt of the command
mean, VSC not work in this mode
yup, figured.

Ok i think the next port of call might be programming the external rom chip in circuit while the drive is on and powered up - if it's indeed as i suspect a parallel flash, then maybe the MCU will click on (for lack of a better term) and initilize the write of the internal rom... could be completely wrong and it may not work and send the drive into a ball of flames ;) but at this point i don't think i have much to loose.
Аватара пользователя
Vlad
Разработчик
Сообщения: 4815
Зарегистрирован: 13 авг 2013, 07:53

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Vlad »

Maybe you can found somebody with PC3K and write ROM?
Severence
Сообщения: 33
Зарегистрирован: 01 янв 2017, 10:28

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Severence »

That would be a good solution, unfortunately i don't know anybody with such tools - if i did - i'd capture communications so us mere mortals could perform such operations manually or implement such a features in other software ;)
Severence
Сообщения: 33
Зарегистрирован: 01 янв 2017, 10:28

Re: Ran WDMarvel and now getting no model and LBA 0 etc

Сообщение Severence »

Hi SRUTSSSSSSSS80,

Having a difficult time translating your fist link (google refuses), but on first glance i can't spot anything of relevence

I've already tried WD ROM recovery tool and had no luck unfortunately, unless it's a more recent version than the version posted over @hddoracle in which case i'll try it again.

your second link is dead 404 - looks like a diy programmer @ this link http://www.tele-sat.org/threads/Програм ... pi_tt.742/ is there something special about the "SPI_TT_v1.027.rar" tool provided

Thanks anyway though
Ответить