wdmarvel.com

Утилита для восстановления HDD WD
It is currently 04 Dec 2020, 17:12

All times are UTC




Post new topic  Reply to topic  [ 789 posts ]  Go to page Previous 170 71 72 73 7479 Next
Author Message
PostPosted: 15 Mar 2017, 19:17 
Offline
Разработчик
User avatar

Joined: 13 Aug 2013, 07:53
Posts: 4708
Severence
Check PM


Top
   
 Post subject: Bad U12 ROM image
PostPosted: 06 Jul 2017, 00:44 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
Hello,

I'm trying to recover a WD 3TB Red Drive (Model WD30EFRX) from a Mycloud setup. I removed it from the enclosure and tried to boot it up in another system via sata connection. The drive would not even spin up. I replaced the PCB with another of the same number (2060-771842-003) and it was able to spin up but Bios did not detect it. I then swapped the U12 rom chip from original PCB to new donor PCB. Now it's back to not spinning up state again.

I though maybe the original u12 rom chip was bad so I found another chip of the same model and programmed it using an external chip programmer after reading the info from original chip but again I'm having the same issue of the drive not spinning up.

Could the Drive somehow be bad internally or the U12 rom image be corrupted? If so what are my options to recover the drive at this point. Thanks!


Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 08:31 
Offline
Разработчик
User avatar

Joined: 13 Aug 2013, 07:53
Posts: 4708
Do you read original U12 image?
Post it if yes


Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 08:59 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
Yes, here's the original u12 image.


Attachments:
hard drive original.zip [246.14 KiB]
Downloaded 259 times
Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 09:23 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
What does that mean? Was the read bad? Do I need to re-read the original rom again or is it already bad? Can it be fixed?
What are my options at this point? Thanks.


Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 17:47 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
Chingis Pm25LD020


Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 18:51 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
I tried the fixed bin file and bios was able to detect the drive. However I'm still not able to detect the drive in Windows.

Also I'm getting the following error message when I try to run the S/A Operations ->Module Operations.
Is this bad? I'm not sure what the next step is to recover this drive so I can extract the data.


Attachments:
WdMarvel_error.JPG
WdMarvel_error.JPG [ 47.33 KiB | Viewed 4138 times ]
Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 06 Jul 2017, 19:26 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
Ok, playing around with WDMarvel some more, I'm not sure how but I was able to get it to detect the drive a little better. There's still a lot of garbage info under Drive section but at least I was able to read S/A Operation->Modules operation (see pic attached). I was also able to read the ROM modules also (see pic attached). Does this mean the drive might be recoverable?

I'm not sure what the next step is. Any advice would be greatly appreciated. Thanks again for all the help.


Attachments:
Drive Info.JPG
Drive Info.JPG [ 22.21 KiB | Viewed 4134 times ]
Rom Read.JPG
Rom Read.JPG [ 51.94 KiB | Viewed 4134 times ]
SA Module.JPG
SA Module.JPG [ 105.85 KiB | Viewed 4134 times ]
Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 07 Jul 2017, 07:40 
Offline
Разработчик
User avatar

Joined: 13 Aug 2013, 07:53
Posts: 4708
Make screenshot of
Heads
Edit config

PS
Are controller channel disabled in Windows device manager?


Top
   
 Post subject: Re: Bad U12 ROM image
PostPosted: 07 Jul 2017, 21:00 
Offline

Joined: 01 Jul 2017, 00:46
Posts: 10
I'm getting the following error. I tried changing head to just 0 from edit head map in ID0A but still same error. Is the head stuck?

Regarding controller channel, I'm not sure what you mean if it's disabled in Device manager. It's an onboard Sata controller.


Attachments:
Head Error.JPG
Head Error.JPG [ 90.7 KiB | Viewed 4151 times ]
Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 789 posts ]  Go to page Previous 170 71 72 73 7479 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited